VLAN em qualquer lugar usando EoIP

VLAN com EoIP no Mikrotik

Esse post é sobre um problema muito comum para quem trabalha com VLANs em seus clientes, e que não quer criar bridges e outras VLANs em seus roteadores que ficaram entre as duas pontas.

Utilizaremos duas interfaces EoIP, uma em cada roteador, vamos chamar os roteadores de mkt-matriz e mkt-filial, esse tipo de tunelamento(EoIP), pode se conectar a outro mikrotik em qualquer lugar do mundo, basta ambos Mikrotiks terem IPs reais fixos (porque dinâmico vai dar queda toda hora na sua VLAN, por isso o melhor é nem pensar nessa possibilidade).

A estrutura que iremos utilizar é de duas filiais com operadores diferentes (ou seja o EoIP será conectado utilizando a internet):

eoip_mbnunes (1)

    Agora para aprendizado vamos interligar os dois roteadores em suas respectivas ether1, e colocar os seguintes IPs: 192.168.100.1/30 no mkt-matriz e o 192.168.100.2/30 (OBS.: lembrem-se esses IPs são inválidos e estou utilizando esses IPs porque é questão de aprendizado, basta você colocar os seus respectivos IPs reais e tudo se resolve).

Então vamos iniciar as configurações no mkt-matriz:

/ip address add address=192.168.100.1/30 interface=ether1

    Agora adicionaremos o EoIP Tunnel:

/interface eoip add name=eoip-matriz-filial remote-address=192
.168.100.2 comment=”EoIP da Matriz para Filial”

    Na interface virtual do EoIP, temos que adicionar a mesma faixa para ambos os roteadores para que possamos fazer uma rota de saída para o IP da outra filial:

/ip address add address=10.10.10.1/30 interface=eoip-matriz-filial tunnel-id=200

    Agora criaremos as VLAN no roteador mkt-matriz:

/interface vlan add name=vlan-empresa interface=eoip-matriz-fi
lial vlan-id=10

/interface vlan add name=vlan-empresa-ether2 interface=ether2
vlan-id=10

    Vamos adicionar uma bridge para agrupar as duas VLANs, com isso basta você plugar um cabo na sua ether2 ao switch da sua rede assim toda sua matriz falará com a filial (e vice-e-versa quando você fizer as mesmas configurações, claro alterando somente os IPs ).

/interface bridge add name=bdg-vlans

/interface bridge port add interface=vlan-matriz bridge=bdg-vl
ans

/interface bridge port add interface=vlan-empresa-ether2 bridge=bdg-vl
ans

    Agora caso a sua filial tenha IPs internos diferente da matriz(digamos que na matriz seja 192.168.2.0/24 e na filial 192.168.1.0/24), temos que adicionar uma rota estática em cada roteador:

no mkt-matriz
/ip route add dst-address=192.158.1.0/24 gateway=192.168.100.2

no mkt-filial
/ip route add dst-address=192.158.2.0/24 gateway=192.168.100.1

    Pronto, agora é só você colocar um computador em uma das pontas, configurar o IP local de onde estiver partindo o teste com o seu respectivo GW e tentar pingar para qualquer outro IP que esteja do outro lado.

Qualquer dúvida só comentar aí.

10 thoughts on “VLAN em qualquer lugar usando EoIP

  1. Pingback: Roteamento dinâmico com o OSPF | | Maurício Nunes

  2. Pingback: VLAN em qualquer lugar usando EoIP | Mundo TI Brasil

  3. Pingback: Roteamento dinâmico com o OSPF | Mundo TI Brasil

    1. mnunesmnunes Post author

      Eudes, resolveria se você tiver somente 1 cliente naquela porta, o que esperamos que a sua rede isso não seja comum ( pq mais clientes em um router, mais dinheiro vc ganha entende? ). Entende o motivo do uso da vlan?

      Reply
  4. Pingback: Roteamento dinâmico com o OSPF — Centúrion TI

  5. AvatarJeferson Machado

    Olá, e se eu precisar passar mais vlans por este mesmo tunel Eoip, estou tentando adicionar na bridge porém os Mikrotiks estão misturando as vlans, uma está pegando dhcp da outra.

    Reply
    1. mnunesmnunes Post author

      Jeferson, obrigado pelo seu comentário.

      Por acaso na ponta você deve estar ligando um switch eu acho. Se estiver esse switch esta com as vlans configuradas na porta do Mikrotik aonde estao saindo as vlans?

      Reply
  6. AvatarCleriton Cangussu

    Bom Dia!
    Foi feita a configuração eu consigo pingar computadores do outro lado. Porém não consigo trafegar (executar um aplicativo).
    O que posso fazer para normalizar?

    Reply
    1. mnunesmnunes Post author

      Se há trafego de ICMP então a VLAN está funcionando. Tem que ver quais sao os requisitos minimos do aplicativo, como MTU e etc. Você tem essas informacoes ai?

      Reply

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.