Roteamento dinâmico com o OSPF

Galera, desculpe a ausência…

Hoje vou tentar explicar da forma mais prática possível. Como sabem não sou nenhum conhecedor da teoria e estou correndo atrás de estudar e aprender como todos vocês.

O que é o OSPF (bem resumido)?

O OSPF é um protocolo que publica para todos os roteadores da mesma instância e suas respectivas rotas e dinamicamente vê qual o melhor caminho (o mais curto) para chegar em seu destino e tratar de forma automática a queda de um link e redirecionando para outro.

Hoje no laboratório teremos um “mundo perfeito” onde 4 roteadores e os links que os interligam tem a mesma banda, sendo que dois deles (o R1 e o R3) terão saída com BGP para outras operadoras (o BGP não será configurado aqui, será apenas para abstrairmos).

Bem, com o já mostramos no tutorial como colocarmos IPs nas ethernets dos nossos Routerboard (Mikrotik), pularemos essa parte e faremos a configuração conforme o diagrama abaixo:

ospf_mbnunes

    Como mostrado no diagrama, teremos que criar uma interface de loopback (lo) para cada roteador executando o mesmo comando em cada um:

/interface bridge add name=lo

    Com a lo criada teremos apenas que adicionar o IP respectivo.

    Agora vamos o que interessa, vamos começar a configurar os roteadores para publicar as suas rotas dinamicamente, para isso temos que colocar em cada roteador 3 configurações:

  1. Temos que adicionar as interfaces que estarão sendo usadas ao OSPF
  2. As respectivas redes locais em cada roteador
  3. E colocar o router-id em suas instâncias (funciona sem, porém não é correto fazer sem configurar isso )

Item 1 –  (farei apenas no R1, e basta repetir os comandos nos outros, porém fiquem atentos para alterar as portas de acordo com cada roteador conforme o diagrama) para adicionarmos as portas usaremos os seguintes comandos e vou explicar cada um deles:

R1

/routing ospf interface add interface=lo authentication=md5 authentication-key=minhaKey network-type=broadcast comment=”loopback” cost=10

/routing ospf interface add interface=ether2 authentication=md5 authentication-key=minhaKey network-type=point-to-point comment=”R1 to R2″ cost=10

/routing ospf interface add interface=ether3 authentication=md5 authentication-key=minhaKey network-type=point-to-point comment=”R1 to R4″ cost=10

OBS.:

  • Temos que colocar sempre authentication=md5 e setar uma senha no authentication-key para que não corra o risco de alguém conseguir ligar um roteador e publicar na sua rede OSPF.
  • E há uma mudança no network-type do lo para as ethernets, vou colocar o link da wiki do Mikrotik que explica as diferenças.
  • O pulo do gato é você aumentar o cost (dos dois lados) para definir qual a rota principal.
  • É sempre bom comentarmos (comment) o máximo possível para que outros técnicos possam entender com facilidade o que está configurado no roteador.

Item 2 – adicionar as redes utilizadas em seus respectivos roteadores, no caso o R1 usa as seguintes redes:

  • 10.200.10.1/32
  • 10.10.0.0/30
  • 10.10.3.0/30

R1

/routing ospf network add network=10.200.10.1/32 area=backbone comment=”Loopback”

/routing ospf network add network=10.10.0.0./30 area=backbone comment=”R1 to R2″

/routing ospf network add network=10.10.3.0/30 area=backbone comment=”R1 to R4″

OBS.:

  • Neste tutorial só utilizaremos uma área, que por default é a backbone, ainda estou estudando para entender melhor o uso de múltiplas áreas, sei que com elas podemos restringir a distribuição das rotas para algum motivo ou objetivo.

Item 3 – Agora vamos alterar a instância de cada roteador (ainda estou estudando sobre ela, não sei ao certo para que ter instâncias diferentes, então atualizo conforme vou estudando), temos que mudar o router-id para o IP do loopback de acordo com o seu roteador. Faremos novamente no R1 e basta repetir o mesmo nos outros (alterando apenas o IP do respectivo loopback )

R1

/routing ospf instance set default router-id=10.200.10.1

No R1 e R3 (que são os roteadores de saída do anel, teremos essa configuração adicional para publicar rota default aos outros roteadores).

/routing ospf instance set default distribute-default=if-installed-as-type-1

OBS.:

  • O comando acima, publica para todos os outros roteadores qual é a saída para 0.0.0.0/0, ou seja quais são os roteadores de borda.

Agora você pode interligar a sua estrutura em forma de anel, brincar de derrubar os links entre os roteadores e ver que tudo estará funcionando a mil maravilhas.

Qualquer coisa só comentar, e obrigado pela força e paciência, sou um simples aprendiz e tento passar a prática que tenho.

Até a próxima!

5 thoughts on “Roteamento dinâmico com o OSPF

  1. AvatarDaniel Campos

    Olá amigo,

    Eu tenho alguns Cisco Aironet 702W Access Point que necessitam do controller da cisco para funcionar (Configurar e faze-lo funcionar). Queria saber se conseguiria fazer isso com algum Mikrotik e se sim, qual? Muito obrigado!

    Atenciosamente,

    Reply
    1. mnunesmnunes Post author

      Daniel, bom dia.

      meu amigo, eu não tenho muito conhecimento cisco, mas acredito que não há outra maneira dos seus Aironet funcionarem a não ser com equipamentos e licenças CISCO. Mas como eu disse seria legal você dar uma pesquisada, mas posso te afirmar que o Mikrotik não faz o que você perguntou. Espero que tenha sido útil.

      Reply
  2. AvatarCarlos

    Olá amigo! MUITO BOM seu tutorial, porém sou iniciante em OSPF, e necessito ao máximo automatizar as rotas, mas meus 2 equipamentos iniciais são edge router, seria o mesmo procedimento?

    Reply
    1. mnunesmnunes Post author

      Carlos, boa noite.

      Desculpe a demora em responde-lo, sinceramente eu não sei, nunca utilizei o edge router, mas acredito que seja bem parecido devido ao protocolo. Bem só se a Ubiquiti nao quis seguir o protocolo ne rs

      Reply

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.